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AppTipSheet – Keeping Your PSE 2019 Catalog Safe
and Healthy
In this AppTip Sheet, we will cover how to protect your photo images from computer crashes
and other catastrophes, such as computer viruses.
General Computer Protection
Protecting your computer from viruses and creating general backups of your computer’s files are
beyond the scope of AppTip Sheet. However, a few comments about these topics are in order
Anti-Virus Programs
I am sure most of us are aware that it is extremely important to protect our computer from
viruses and other types of malicious software. Moreover, it has been my experience when I ask
students about this, most feel they have at least some form of anti-virus software running on their
computer. I use Microsoft’s Defender, which is part of Windows 10.
However, the student responses are not quite so encouraging when I ask how often they update,
or do they ever update their anti-virus program. Blank stares are often their answer. Whatever
anti-virus program you use on your computer, you must routinely and regularly update its “virus
definitions” data. Hundreds of new viruses enter the internet each day, and to be effective, your
anti-virus software must be aware of these. That being said, most anti-virus programs will do this
somewhat automatically, but you should check the settings to make sure updates are routinely
applied. Additionally, most modern anti-virus programs provide some sort of real-time
protection. They detect/isolate the virus before it has a chance to do any damage.
Computer Backup Programs
In addition to protecting your computer from viruses, you need to have some sort of procedure to
back up the photos and other important data that are stored on your computer. Even if you are
adequately protected from malicious software, hardware problems, specifically disk crashes, can
occur with little or no warning. In an instant, all of your photos and other important data, and
programs you have on your computer can be wiped out.
Disk drives generally have a relatively short lifespan. It is not uncommon for a hard disk to fail
after only five years or even sooner. I had the C-Drive on my prime computer suddenly fail after
about four years. If you do not have your digital images also stored elsewhere, you could easily
have them and the memories they illuminate disappear. Many people today use some sort of a
backup program that runs semi-automatically or even continuously. These programs generally
work well and when set up properly provide a high degree of protection from a loss of data due
to a virus or a hardware problem.
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Also, protecting your data and photos using backup program that stores a copy of your data
online away from your home is becoming more popular and practical today. The obvious
advantage here is that if your home is destroyed, your photos and data on your computer are
protected. The cost of making use of one of these online storage solutions has come down in
recent years. This approach is one example of the growing technology often called “cloud
computing”.
In earlier years, either using a local backup program or one that stores your data online often
slowed down your computer as it tried to do its normal tasks. However, the power of computers
bought in recent years, and improvements in the backup programs and operating systems have
reduced this problem significantly.
My Overall and Current Approach to Data Backup
I made sure I put the word “current” in the title of this section. With the growth of my photo
catalog and advances in technology, I routinely review and may fine tune my overall strategy in
the future. However, what I describe here has worked for me up to now and has stood the test of
providing relatively quick data recovery and normal system operation over the years. I have
suffered a major failure on my C-Drive and lost little time and very little data. Also, backups can
play a key role when you buy a new computer and want to transfer your photos and data to it.
In general, I am much more concerned about protecting my data, photos, and videos than I am
about preserving the programs I have installed on my computer. I always keep the CD/DVDs
containing the program and its serial number. If it is a program I downloaded (I have a ton of
those.), I have copied it to a CD, external drive or some other media and have its serial number
saved. So, if I suffer a disk crash, or buy a new computer, I simply reinstall the software. True, I
am not backing up and running in minutes, but the programs I rely on are ready to go in a couple
of hours or so. Invariably, I find that I do not need some of my previously installed programs. So,
this provides me a way to clean house, which I find refreshing.
So how do I back up my non-photographic data and information currently? I use a small program
called Karen’s Replicator or Microsoft’s Sync Toy. I find they are adequate for my needs. I only
use it to back up data and not my operating system’s critical files. This has worked for me for
many years, but I do not recommend this for everyone. I am sure there are better solutions out
there, as I alluded to above.
A few years ago, I started backing up my files on my prime computer using Carbonite, a cloudbased service. Currently, I use it to back up the four internal disk drives and one of my external
drives on my computer. I consider this my doom’s day backup. My photos and data files are
backed up automatically. Carbonite will also manually back up my video files. The company
offers plans that include multiple external drives and computers. Working in the background, it
took Carbonite a couple of months to do the initial backup, but now everything is kept current in
real time. My backed-up files are over 3 TB of cloud storage space and number several hundred
thousand. I hope I never have to use its restore capabilities, but it is comforting to know they are
there if needed.
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More recently, I moved all my photos and videos to a Drobo system which is configured to
automatically back them up in basically real time. So far it seems to be working well and does
not slow down my computer significantly. Currently, my photos and videos take almost 3 TBs
on this system.
As described in the next section, I rely on the Backup/Restore commands within PSE 2019 for
my local backup of my photos and videos. This has worked well for over ten years, during which
time I have suffered a hardware failure, and upgraded computers several times.
An Important Tip: Before leaving the subject of back-ups in general, I want to pass on the
following. For whatever reason, when computer technicians are called upon to fix a computer or
set up an automatic back-up program, they fail to deal with the PSE Catalog file itself. The result
is that once the repair is complete or the backup setup is put online and then used to restore the
computer to its functioning state, the PSE Organizer does not operate properly. The thumbnails
are visible in the Media view, but they all have question marks in the upper right corner, which
means PSE cannot find the photo itself. Or worse yet, the Catalog itself is not found. This is not
an uncommon problem, and I have helped many people recover from it.
Here is the tip. From the Organizer, click on Help > System Info. As shown in the figure below,
the screen that appears, displays a variety of information, including the name and location of the
currently opened Catalog.

It is this file that needs to be backed up and properly restored for PSE’s Organizer to work. This
is a good thing to point out to your computer guru before he begins to fix your computer or set
up a new one for you.
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Maintaining Your PSE Catalog
I separate maintaining my PSE Catalog into two different types of activities, general
maintenance tasks, and backing up the catalog. The next two sections address these activities.
Routine Maintenance Tasks
The maintenance commands are accessed by clicking on File > Manage Catalogs from the Menu
bar as shown in the figure below.

As shown in the figure, all of the commands are grayed out, since none of the Catalogs are
selected. Selecting a Catalog will highlight the various commands.
Rename: This command is used to rename your catalog. Click on the catalog and follow
the screen prompts.
Move: This command is used to move the Catalog itself. As we discussed earlier, the
Catalog is not your pictures. After a Backup/Restore process is done, the actual Catalog
file may not be exactly where you want it. This command allows you to move it to
another location.
Remove: This command allows you to delete a Catalog, you no longer want to use.
Remember, removing a Catalog does not affect the images in that Catalog. It simply
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deletes the Catalog folder. The Catalog folder contains the thumbnails of your images
among other information needed to manage your photo collection. It is not a terribly large
file, so it does not require a lot of disk space. You can just keep unused Catalogs on the
list if you prefer, but I would suggest removing any old Catalogs that are no longer
needed.
The bottom two commands, Optimize and Repair, are what we will use periodically to keep the
PSE 2019 Organizer running smoothly. You should run these commands every couple of weeks
or so. However, if you don’t, nothing bad is going to happen. Also, running both of these
commands when you are troubleshooting a problem with your Catalog is one of the first things
you should do.
One more thing to notice in the figure is that it displays the current PSE 2019 Catalogs. You will
most likely need and have only one. As the figure shows I have several. Also, in this same figure
you see the command for converting catalogs from previous versions, and for creating brand new
Catalogs. Normally, you will not need to use these two commands.
Running the Repair Command
The Repair command has the PSE 2019 Organizer examine itself, find and hopefully correct any
internal database errors it finds. You can run this command even if you are not experiencing
problems with the Organizer. After you select Repair, the following status bar is displayed.

After a short time, the following Message is displayed. For large Catalogs, this may take a few
minutes. If the things look good with the Catalog, the figutr below is displayed.

At this point, click on Repair Anyway. This will force the Catalog to be internally rebuilt.
Depending on the size of your Catalog, it may take many minutes or longer. If you use the
various photo analysis capabilities within the Organizer, you should also click on Re-index
Visual Similarity Data. But this will increase the time. I do not enter the check here, because I
generally do not use Media Analysis. However, selecting it, will do the best job cleaning up the
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Catalogs internal structure, and may solve errors encountered during the Backup/Restore
process. The figure below is displayed once the repair has been completed.

Running the Optimize Command
Clicking on the Optimize button immediately begins optimizing the thumbnail cache. This
operation may take several minutes to complete, again depending upon the size of your Catalog.
To reiterate, it is a good idea to run these two commands on occasion, even if you are not having
any problems with the Organizer. And they are among the first troubleshooting steps if you are
having problems or the Catalog’s commands are running slower than usual.
Reconnecting Image Files
This command is one that hopefully you never have to use completely, because you have obeyed
the Cardinal Rules. You have never renamed, moved or deleted files without using the
applicable Organizer commands. However, I include it in this section, because you should
check for files that need reconnecting periodically. I would suggest you run the command as
described below weekly, if you are actively working with PSE 2019. That way if some files have
become disconnected, you will discover the problem quicker, and may even remember what you
did that caused the problem. That will make reconnecting them easier.
As shown in in the figure below, click on File > Reconnect > All Missing Files from the Menu
bar.
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After about minute or so, depending upon the size of your Catalog, the message shown in the
figure below is displayed if you have no disconnected images.

If you do have one or more images that the Organizer cannot find, a Searching box like the one
below appears, and the Organizer will try to find the missing images and reconnect them
automatically. Click on the Browse button in the search dialog to stop the searching.

At that point you have several options on how to proceed manually to find the proper image and
then reconnect it. Dealing with this situation is beyond the scope of this tutorial. However, if you
click on the Missing File link in blue, you will get some hints on how to find the missing files
manually.
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